You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
It would be great if the deps could be updated due to the security vulnerability of the sqlparse version
We take a dependence on this package and our governed repositories scans for violations.
dependency sqlparse==0.2.4 as a security violation.
StripComments filter contains a regular expression that is vulnerable to ReDOS (Regular Expression Denial of Service)
The formatter function that strips comments from a SQL contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). The regular expression may cause exponential backtracking on strings containing many repetitions of '\r\n' in SQL comments.
It would be great if the deps could be updated due to the security vulnerability of the sqlparse version
We take a dependence on this package and our governed repositories scans for violations. dependency sqlparse==0.2.4 as a security violation.
StripComments filter contains a regular expression that is vulnerable to ReDOS (Regular Expression Denial of Service)
The formatter function that strips comments from a SQL contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). The regular expression may cause exponential backtracking on strings containing many repetitions of '\r\n' in SQL comments.
Recommendation
Upgrade to version sqlparse - 0.4.2
Hi everyone,
I've created a modernized fork of mssql-cli that addresses the compatibility issues discussed here.
Activity
cwegener commentedon Apr 5, 2022
Running
pip install --upgrade cli-helpersafterpip install mssqli-cliis how I was able to use mssql-cli on Python 3.10ggt-steven-combs commentedon Apr 21, 2022
I can't even use this because of the dependency issue. Is there a fork or a PR for this yet?
swells commentedon May 13, 2022
It would be great if the deps could be updated due to the security vulnerability of the
sqlparseversionWe take a dependence on this package and our governed repositories scans for violations.
dependency
sqlparse==0.2.4as a security violation.Recommendation
Upgrade to version sqlparse - 0.4.2
rubgithub commentedon Jan 19, 2026
Hi everyone,
I've created a modernized fork of
mssql-clithat addresses the compatibility issues discussed here.You can find the code and the fix here:
👉 mssql-cli (branch: py311-fix)
Quick Summary:
SqlToolsServiceto .NET 8.0.