You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Maintenance: drop support for Python 3.10 on February 1, 2027 #8735
The first release on or after February 1, 2027 will require Python 3.11 or newer (requires-python >= 3.11), will not be tested on 3.10, and the public Lambda layer will stop being published for python3.10.
Existing functions keep working. Versions of Powertools for AWS Lambda (Python) released before that date keep working on 3.10; pin to the last one if you need more time. We just stop guaranteeing compatibility from then on.
Lambda itself will block creating new python3.10 functions on July 29, 2027 and updating them on August 31, 2027, so the upgrade is coming either way.
We recommend upgrading your Python 3.10 functions to Python 3.12 or newer. To list the functions still on the runtime, run this in each region you use:
aws lambda list-functions --function-version ALL --region <Region> --output text --query "Functions[?Runtime=='python3.10'].FunctionArn"
Which area does this relate to?
Automation
Solution
Tracked here, one PR when the date comes: bump requires-python and the classifiers in pyproject.toml, remove 3.10 from the quality_check matrix and from layer_v3 (Dockerfile, install_libraries.sh, layer_stack.py, canary_stack.py), update docs/getting-started/install.md, docs/upgrade.md and docs/automation.md, and the Python badge in the README. Same shape as #8439, which retired 3.9.
Activity